Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #8811


    The theme’s great, but I’m having a couple of issues, mainly with uploaded images & galleries.

    The background gallery slider is the main thing I’m after, but it doesn’t like actually appearing. The image uploader seems patchy, and can’t grab stuff from the library. Mainly, though, even when I have a gallery of images selected in the Edit Page gallery field, it won’t show on the page. For example, the first of these links has a working gallery, the other doesn’t, but all settings are the same, both have galleries ‘uploaded’:

    Looking at the code with Firebug, I can see the second has no images, but how can I fix this?

    Also, the main background image, for all pages in the theme options, I’ve uploaded on, but now can’t get rid of it to check it’s not clashing. Should this image stay viewable in the options panel?

    I’ve disable all plugins, but I’m thinking I may have to completely re-install wordpress, flashlight, the lot, as it seems to be getting quite confused, or kicking into life at random. It’s not a cache problem, same in other browsers and other things update immediately.

    Love the design, but really really grateful if you could help.



    The second link seems that you have only 1 image in the gallery hence why there is no back/pause/forward button

    I’d also double check your default settings in the theme panel


    Hi, yeah, that’s the default background image, set in the Theme Options panel. The actual gallery has four images, which should be fading through just like the first. But all settings between those two pages are effectively the same (only difference being the particular jpgs used) (and to be honest the first link didn’t appear straight away so I don’t think it’s something unrecognized with the photos). Thanks


    On the page editor, what option do you have set on the “Gallery Layout” on the gallery options section.


    Background Slider Only.


    Background Slider Only.


    I am having the same issue as katehopwoc with the background slider. It appears that all the settings are correct, just seems a bit buggy and the images I upload are not showing – Any suggestions?


    Pannsy – I’ve kind of managed to make it work as it should. After probably fifty attempts at creating galleries, I’ve narrowed it down to this:

    Create New Page

    Bung your text in the box, or whatever you’re having in the page body (mine are only very simple in terms of content)

    Upload button. Drag files into the multi-uploader.

    Wait for them to upload.

    When you’ve got a list (or just one, however many you’re having), click ‘show’ to edit their details if you want (can do this after in media library once you know it’s working).

    Now – here’s where mine started going nuts.

    Click Save All Changes ONLY on the lightbox page with the drag box & the single option to upload from computer.

    DON’T click on Insert To Post within an individual photo editing box, it’ll fail.

    Should then change slightly and give you options to select from URL, gallery (with Number images already there in brackets), Library.

    DON’T click on those options, it’ll fail. Also don’t click again on save all changes, no need unless you’ve changed them.

    DON’T click on Insert Gallery, I’ve found this does nothing.

    JUST CLOSE the lightbox viewer.

    Click Publish or Save Draft right away. Page should re-load and hopefully will display correctly in a preview. If you need to change anything, (layout, parent etc) do it after this point.

    Some of these points may be unnecessary, but like I say after 50 attempts and it randomly clicking into action, this worked for me so I’m sticking with it.

    I think the problem here comes with uploading the images. While trying to figure it out, I noticed in the media library the photos that would produce the gallery would say they’re Attached to something like ‘ (Purchase code hidden if logged out) ‘, and the ones that wouldn’t would say they’re attached to e.g. ‘ (Purchase code hidden if logged out) -contentfeb0212′. No idea why, I must have done something different to interrupt this upload but I’m stumped as to what.

    So I had both library and new page open at once, to check they were going in okay.


    A key detail to this thread is to make sure that Settings > Reading > Frontpage is set to the correct page.

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Background Image Galleries’ is closed to new replies.