Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #23115

    Hi Guys!

    I am encountering a few problems with the product images and I was hoping you’d be able to help me because I can’t seem to figure out what’s happening.

    Here’s the link to my site

    Not sure which order to post my issues so I’ll just run with it and post screenshots and specifics next to each issue

    What causes an imported graphic to end up in the “Unattached” category in the Media Library?

    1) I’ve been working on replacing all the 12k graphics I currently have on my site by replacing theold image name in the data file to the new image name and doing a “merge” using the Woocommerce CSV Import Suite (Woocommerce support is not helpful with any type of issue whatsoever :( )

    I go through the normal routine of my imports timing out..etc…etc…I’m used to that now

    However, after the merge I’m finding that my graphics have somehow been moved to “unattached” resulting in a majority of the products to display no featured image or a broken linked image if that makes sense. Here’s a screenshot of some of the close to 2000 graphics that somehow failed to attach to the product it was imported with….

    2) I’m finding that there are some images that no matter what I do, re-size, force regeneration etc..etc.. they are completely disproportionate to the specified sizes. Keep in mind, I haven’t changed any of my image sizes, I’ve forced regeneration several times without any improvement.

    Here’s an example of what I expect to see (this is under category “Electrotherapy” for reference )

    Here’s what I’m seeing throughout my site with no reason I can determine (This is under the “Bath Safety” Category)

    3) In this screenshot you’ll notice that the wording in the Blue section beneath the Main Menu displays “Viper Plus GT Wheelchair with Flip Back Removable Adjustable Desk Arm and Elevating Leg Rest” which is the first product on the top row displayed under this particular Brand. This happens all the time and can become confusing. My easiest solution is to remove the entire Blue section below the menu/above the main content of the page, but for some reason I’ve completely forgot where I added it in to begin with???

    Here’s another example –

    So essentially the entire block below that menu where the words “50 PSI Compressor” are displayed and the entire blue section I just want to remove altogether, can you remind me where I do this?

    4) The bullets that are displaying in the First row beneath the heading “Product Manufacturers” it’s the horizontal list of a-z that are covered with a bullet and I swear I’ve tried everything including woo support, they are not helpful at ALL…

    I had tried modifying the code several different ways but nothing worked. Ideally I’d like to see NO bullet and the Letters Capitalized A-Z but I’ll settle for the bullet being removed if that’s the only way to fix the appearance without having to modify a bunch of different files and potentially causing issues. This is under the Main Menu “Shop” Sub-menu “Shop by Manufacturer”

    5) One last question, the prices listed for products throughout the website seem to all be included in the woocommerce-mod.css file in this section

    #top .price, #top .price span, #top del, #top ins{


    text-decoration: none;

    font-size: 14px;

    line-height: 18px;

    font-weight: bold;


    I was trying to just increase the size that is displayed on the individual product page so it stood out more and realized after I changed it that the font size for prices throughout the entire site were affected by modifying the font-size in the woocommerce-mod.css file. Is there a quick way to just increase the Product Page Price while leaving the other areas of the site where prices are displayed as is?

    For some reason I thought the price was displayed in a different location on the product pages but perhaps I’m confusing this with the Abundance theme website I just finished…not sure lol….

    This is what it looks like now it’s quite tiny:

    I do believe that is all I had for questions…As always your assistance is valued :)

    I removed the password protected login so you should be good to go when visiting the site.

    Let me know if you have any questions or if I need to clarify anything.




    Hi Kim,

    Seems like there is a combination of things going on. My guess is that in the timeouts, the server may sometimes be having issues completing certain tasks. Just a guess but it could have something to do with inconsistent results.

    1) I’m not familiar with how the csv import works but I’m not sure there is anything we can do if the plugin isn’t doing its thing right. With Replete, Kriesi specifically didn’t alter the backend funcitons of the products so that woo commerce would have completely control over the output and the theme only wraps the fron end in styles.

    2) Image sizes can be tricky. We would need to see a specific instance to dig further but my guess, based on the images is that they aren’t set to crop for the single product items and/or the sizes in the woocommerce catelog image size settings aren’t consistent with what you want changed.

    Something along those lines. It could also be an image that isn’t wide enough for the space but tall enough, so that when wordpress tries to adjust it no new image is generated but instead it just puts it in the front end and then the css stretches it to fit.

    3) I don’t know just from the screenshot where this is from, what kind of page that is either. It could be a template builder template, a page name, category name or something like that.

    4) The bullets are getting a :before bit of css added on to them so anything you would try to alter the actual list item would do nothing. Try targeting that header area, whatever css selector it is, and using something like:

    #top .yourclassselector li:before{ content:" ";}

    5) You can use the single-product class selector to make changes only to the single product pages. Eg:

    #top.single-product .amount {
    font-size: 14px;




    Hi Devin

    Sorry for the delayed response.

    I managed to fix the bullet issue I was having by commenting out a line or two of code in one of the style sheets (can’t remember which one off the top of my head)

    I also created a quick fix for the prices displaying on the Single Product pages.

    In regard to the server timeouts, I was just making a statement and don’t require any assistance with the csv imports as it often indicates a problem within the csv file that causes the process to stop…inconsistent and irregular formatted data is always a blast ;)

    The image issues are the only issues I still need some help figuring out.

    If you go back to my original post at the top of this thread you’ll notice that I included the screenshot and the specific category on my site where you can see the live view of what is captured in the screenshot. You could either select the category from the drop down menu or type the word in the “Search for products” box and it will display the products.

    If it’s easier I can send you direct links to each instance, just let me know.





    The image issue is simple. You need to specify a width and a height (not 9999) and have crop activated. The only way that you will get a huge rectangular image as your demo image showed, is if you have a set width (250px lets say), 9999 is your height and you have no crop set. Regeneration is not an exact science and the more it is used the worse your images will become from all the resizing. Also its a very memory intensive process so sometimes you may think that the regenerator finished and there are no errors, while in reality it may have skipped a good number of the images, especially if its peak hours for your server.

    The trick with simple image sizes, is to make sure that you get the right size from the beginning and never have to use the regenerator. Personally if there are under 50 images, I run them manually so that I know for a fact, each one gets added at the correct size and there are no surprises down the line. Regenerating 10,000 images , I would say 100 images at least were skipped.

    You can try this other highly rated regenerator and compare the results.`



Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Back to some image issues and a random issue or two’ is closed to new replies.