Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #3735

    Hi guys, this morning I purchased aviaslider but I’m experiencing some problems.

    The problem is that the first image fade in correctly but then the second, third, fourth etc.. pictures pop in without any animation.

    Everything seems to be in the right place, the buttons are there and working, the pictures are there, prettyphoto works, it’s just the animation that doesn’t start between one picture and another.

    I followed the instructions, and I also checked everything comparing with the demo index contained in the zip file, but I can’t figure out how to solve the problem.

    This is how the SCRIPT are configured:

    <script type=’text/javascript’ src=’js/jquery.js’></script>
    <script src=”js/prettyPhoto/js/jquery.prettyPhoto.js” type=”text/javascript”></script>
    <script type=’text/javascript’ src=’js/jquery.aviaSlider.js’></script>
    <script type=’text/javascript’ src=’js/custom.js’></script>

    Of course I’ve got a JS folder with all the .js in the inside.

    Then this is how the HTML is configured:


    Of course the pictures are correctly linked.

    Then I copied the style CSS part into my main CSS stylesheet, and did the same for the prettyphoto css; in fact I guess the CSS is ok because pretty photo works fine and so the general CSS stylesheet.

    I really cannot understand what’s wrong with my config…can somebody help me?

    PS. forgive my mistakes…I’m italian ;-)



    can you post a link to your site/test server. The code seems to be right for me but maybe there’s a conflict.


    Hi Dude thanks for the reply! I published the html page so that you could see the problem and….it’s working! :S

    Is it normal that in local the script doesn’t work and then when when everything is online it’s perfect?

    Anyway this is the temp webpage can you check if there’s something wrong with the code?

    Many thanks.



    Strange – the js slider should work offline too. Maybe the paths weren’t correct. However, glad that the slider works when it’s online.


    I rebuilt the webpage from the beginning, and now the script seems to work properly even offline ;-)

    Just one more question Dude, I have to use the <div> </div> instead of li /li

    as described in the documentation:


    The problem is I can’t understand the first part…how or where do I have to change the default value slides:”li” into slides:”.featured”?

    The only thing I did was this:


    But this way the moment I load the page I can see only the loading button and no pictures at all.

    Thank your assistance Dude, I really appreciate that ;)


    Ok solved this one too: didn’t know I had to edit the jquery.aviaslider.js :D

    Now I got one last little problem: in Internet Explorer the buttons are shown on the bottom left while in firefox and chrome they’re correctly positioned on the bottom center. Any solution to this?



    can you post a link to your test site. On this site: the slider doesn’t display the slider controls at the moment so I can’t test/investigate the css with IE developer tools.


    Hi Dude, as always thank you fot the support.

    The other link is outdated, I’m now testing it on this page:

    Here you can notice the strange behaviour of the buttons in IE:


    Mmm… it seems like IE has problems to align the elements in the center. I don’t know why but it doesn’t accept the mrgin auto attribute. The only chance I see is to use an absolute margin value like:

    margin-left: 350px;

    Adjust the margin value as you like (i.e. so that the controls are center aligned).


    Hi I am having a problem with aviaslider only in Internet explorer, the images are not changing or not appearing at all.


    Any help would be much appreciated.

    Thanks nB



    I tried your website with IE9 and 8 and didn’t notice a display error. Which browser version do you use at the moment?


    I’m going nuts trying to figure out what is wrong with my code but for some reason the images and controls in my aviaslider aren’t working. Could you take a look and maybe point me in the right direction?



    I think one cause could be that you load jquery twice – remove one of these lines:

    <script type="text/javascript" src=""></script>
    <script type="text/javascript" src=""></script>


    I tried removing each one and still nothing.


    I think I found the reason – replace following code:

    <script type="text/javascript">


    <script type="text/javascript">

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Avia slider not working’ is closed to new replies.