Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #21600


    I’ve been trying for HOURS/DAYS to figure out how to ADD products to the cart on the “Show Details” Page. Every time I select the product button listed on the lightbox: “Show Details” – and I click on the “Add to Cart” button – nothing happens. I have disabled all plugins and it still doesnt work…

    Is this the woocommerce update/Ajax bug that I have seen in other recent posts?


    specific link: (Purchase code hidden if logged out) -hair-vitamins/

    Any advice?



    I’m not sure if this is a theme issue or a woocommerce, third party extension/plugin or server issue. The strange thing is that your server simply ignores the add to cart action – even if you follow the direct “add to cart link”: (Purchase code hidden if logged out) -hair-vitamins/?add-to-cart=795

    – eg on the demo page: the cart link is:

    and every time you click on it WooCommerce will add another item to the cart. This cart link (and the “add to cart” function and the “add to cart” process) is not affected by our theme at all.

    I’d try following:

    1) Deactivate all plugins except WooCommerce and check if this fixes the cart issue.

    2) If 1) does not help try to switch to another theme (like the default TwentyTwelve theme) and check if this helps.

    3) If not, try to re-install WooCommerce 2.0.5

    4) If it still doesn’t work try to increase the allocated server memory:


    Hi Dude,

    Thank you for your reply. I tried all of your suggestions and unfortantately none them fixed the issue.

    I even depleted Replete Theme and uploaded again.

    1. I deactivated all the plugins – this didnt fix the issue.

    2. I switched to TwentyTwelve – it didnt fix the issue.

    3. I deleted and reinstalled WooCommerce 2.0.5

    4. I tried to allocate more memory from the server: define(‘WP_MAX_MEMORY_LIMIT’, ‘256M’);

    None of these worked at all.

    I am not sure how to procede from here. Can I send you my login


    Can I send you my login to your email? And see if I am doing something wrong?

    Thank you,

    Desperate here…


    I spent some time on the phone today with my hosting provider (godaddy) to see if there was anything I can do to increase the memory. I even created a new php.ini file and increased the memory there. But that also did not work.


    Please ask your hosting provider (godaddy) if they can provide error logs or help you to debug the issue somehow. If 1-3) didn’t solve the issue it’s definitely a WooCommerce and/or server configuration issue because we eliminated all other “possible culprits”.


    Okay, I will call them and let you know. Thank you


    I spoke to Godaddy – and they dont provide error logs for site based failures. Today, I completely uninstalled wordpress and reinstalled WP – and also Re-installed Replete Theme.

    I have the beginnings of a website – but it STILL DOES NOT WORK. It wont response to the “Add to Cart” when user clicks.

    I urgently need this to be fixed. Maybe I am doing something wrong on my Admin side?

    Any more suggestions?

    Thank you


    Hi there guys, I’m still struggling with this. Any suggestions…


    To be honest I’m not sure how I can help you in this case because

    1) The culprit is not the theme (because a theme switch doesn’t change anything and you’re still unable to use the add to cart button).

    2) The hoster does not provide any logs which would help us to find the problem.

    I’d suggest to install woocommerce on another server from hoster. We have no other user reports regarding a broken add to cart function. Some users report that they’ve an issue with the ajax add to cart – however that’s a different problem and not related to the standard “php based” add to cart functionality.

    Imho this is not a plugin/wordpress/woocommerce configuration problem but a server problem and you can’t do anything on the admin side.

    You can also try to contact the woocommerce support staff: – maybe they stumbled over a similar problem in the past.


    Ok, thanks, I will try to contact woo theme support.



    I hope they can help you. Nevertheless I recommend to use another hoster – godaddy causes a lot of headaches.



Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Add to Cart is Failing’ is closed to new replies.