Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #18194

    I recently purchased the Sentence theme and I love it, but one of my readers just mentioned that she got an error when trying to post a comment. I tried it for myself, and had the same problem. When you click on submit comment, it tries to send me to, where xx.xx.xx.xx is my IP address… I’m baffled as to what would be causing this, but would really like this fixed ASAP!



    Did you try to deactivate all third party plugins? Maybe a plugin hooks into the comments system and causes this error.




    Yes, I only had 5 active plugins (none of them related to comments) and I just deactivated them all, emptied my caches and tried commenting again, but I encountered the same error. Not sure if this is a factor, but I’m on Multisite. Wouldn’t think that that would be an issue, but I figured I’d mention it.


    OK, I figured it out. It was a rule in my htaccess file that was causing this. In an effort to block spam, I added a rule (below) to redirect people trying to access wp-comments-post.php directly back to themselves. I hadn’t updated the rule to include this domain:

    RewriteEngine On

    RewriteCond %{REQUEST_METHOD} POST

    RewriteCond %{REQUEST_URI} .wp-comments-post.php*

    RewriteCond %{HTTP_REFERER} !.** [OR]

    RewriteCond %{HTTP_USER_AGENT} ^$

    RewriteRule (.*) ^http://%{REMOTE_ADDR}/$ [R=301,L]

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘404 error when trying to post a comment’ is closed to new replies.