Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #2063

    Hi. I have read all the posts, and done all the things suggested, but with no resolution. I changed the php file using the new code you provided in prior threads, added the WP “no category” plug in (although I know it has no impact), I have flushed the permalink several times, rewrite page, changed the permalinks back to default, then tried again, emptied my cache, tried on different browsers…still getting 404 error. URGENT, please help.

    By the way, when I change the permalinks back to default, all the pages get the page_id’s, but the portfolio get’s the actual page name


    What does that mean?


    your portfolio subpages seem to be working… however, when clicking the portfolio link directly, nothing appears. is that the issue you’re having?


    Yes that is the issue. Thank you for responding.



    The problem was caused because the permalinks needed flushing – something you did when you visited the Permalink page and changed the structure.

    The individual portfolio pages seem to be working now – eg

    Feel free to change your permalink structure now :)



    Thank you so much for taking the tiime to help me try to resolve this. The problem isn’t fixed though. When I change the permalinks to: Month and name (, I lose the portfolio link – the 404 error message. When I change it back to default (, the other pages get a “PAGE NUMBER” and the Portfolio links get actual page numbers, so it’s one or the other.

    Check it now if you don’t mind, I’ve got the permalinks set to Month and Name and now you will see I get the error 404 message.


    something is configured to use %tag%/%post-name%/ and WP is not replacing it with the correct information

    did you change the permalink on the actual post? (Dashboard -> Post -> Edit Post -> Permalink)? or something with the setting “%tag%/%post-name%/” ?


    Thanks for sticking with me on this. Where we are at now is that the regular pages are functioning, the portfolio main pages are working, but when I click on a link that is in a “sub-category” of portfolio, that’s where the link goes to 404. I’m happy to pay you to help me resolve this, I’m trying everything to get it fixed.


    I got your mail and answered.


    I am having the same issue. Please reply with the solution


    According to this thread: (Purchase code hidden if logged out) -has-incorrect-link you solved the problem. I close this thread now.

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘404 Error – Portfolio still even after following instructions’ is closed to new replies.